
Introduction

McAfee Enterprise Client Administrator is a powerful administration tool you can use to configure PC Medic for enterprise-wide 
operation. An easy-to-use administration console allows you to establish groups of workstations 
(e.g. sales, engineering, admin, etc.), select and activate PC Medic features for particular user groups, and schedule PC Medic 
diagnostics that run in the background at a predetermined time. The Configuration Manager console can also collect statistics, 
alarm notifications, and other information you can use to assess the health of your network.

    Related Topics 



Launching the McAfee Client Administration Console

Once you have installed McAfee Enterprise Client Administrator on the computer you want to use to configure PC Medic for 
network operation, you can use the McAfee Enterprise Client Administration console. To create, edit, and distribute rules and 
schedules that govern how PC Medic works to protect your network. 
To launch the McAfee Enterprise Client Administrator, click Start, point to Programs, then to McAfee PC Medic. Next, choose 
McAfee Enterprise Client Administrator.

    Related Topics 



Contacting McAfee

McAfee maintains a support staff with expertise in the each of the areas listed below. Click any of these topics for more 
information:

Customer Care 
McAfee Training 
Technical Support 



McAfee Training
For information about scheduling on-site training for any McAfee product, call (800) 338-8754.

 Related Topics 



Technical Support

McAfee is famous for its dedication to customer satisfaction. We have continued this tradition by making our site on the World 
Wide Web a valuable resource for answers to technical support issues. We encourage you to make this your first stop for 
answers to frequently asked questions, for updates to McAfee software, and for the latest news and information. 

World Wide Web www.mcafee.com 

If you do not find what you need or do not have Web access, try one of McAfee’s automated services:

Automated Voice and Fax 
Response System

(408) 988-3034

E-mail support@mcafee.com

McAfee dial-up Bulletin Board 
System

(408) 988-4004
1200 bps to 28,800 bps
8 bits, no parity, 1 stop bit
24 hours, 365 days a year

CompuServe GO MCAFEE

America Online Keyword MCAFEE

If the automated services do not have the answer you need, contact McAfee at one of the following numbers Monday through 
Friday between 6:00 a.m. and 6:00 p.m. Pacific time.

For corporate-licensed customers:

Phone (408) 988-3832

Fax (408) 970-9727

For retail-licensed customers:

Phone (972) 278-6100

Fax (408) 970-9727

To provide the answers you need quickly and efficiently, the McAfee technical support staff needs some information about your 
computer and software. Please have this information ready before you call:

Product name and version number
Computer brand and model
Any additional hardware or peripherals connected to your computer
Operating system type and version numbers
Network type and software version numbers
Contents of your AUTOEXEC.BAT file, your CONFIG.SYS file, and your system LOGIN script
Specific steps to reproduce the problem, if applicable

 Related Topics 



Customer Care

To order products or obtain product information, we invite you to contact our Customer Care department by calling (408) 988-
3832 or by writing to the following address:

McAfee Associates, Inc. 
2805 Bowers Avenue
Santa Clara, CA  95051-0963
U.S.A.

 Related Topics 



Installing McAfee Enterprise Client Administrator

McAfee Enterprise Client Administrator has two parts: PC Medic Administrator and PC Medic Client. You must install PC Medic 
Administrator on the computer you want to use to control PC Medic operations on your network. Install PC Medic Client on all 
systems you want to configure from your administrative system.
Before you begin, review the system requirements for installing and running McAfee Enterprise Configuration Manager.

Administrator system requirements 
Client system requirements 



System Requirements

McAfee Enterprise Client Administrator has two parts: PC Medic Administrator and PC Medic Client. You must install PC Medic 
Administrator on the computer you want to use to control PC Medic operations on your network. Install PC Medic Client on all 
systems you want to configure from your administrative system. 
Before you begin, review the system requirements for installing and running McAfee Enterprise Configuration Manager.

Administrator system requirements 
Client system requirements 



Windows 95 system requirements

To install PC Medic Administrator or PC Medic Client on a Windows 95 system, you must first 
1 Install the Windows Remote Registry Service.

 Note: Refer to the Windows 95 Resource Kit on your Windows 95 CD-ROM for information about the Remote 
Registry Service.

2 Enable the User-Level Access Control option in the Network control panel. 
3 Select the Enable Remote Administration of this Server option in the Passwords control panel and enter the name of an 

appropriate administrator.

 Related Topics 



Administrator system requirements

The administrative system must have:
· A 486 or later processor 
· 8MB RAM
· Windows 95 or Windows NT 4.0 
· An SVGA 256-color display with 800 by 600 pixel resolution
· Free hard disk space:

      For PC Medic application files: 20MB

      For documentation files: 1mb

 Related Topics 



Client system requirements

The client systems must have the following minimum requirements:
· A 486 processor or better
· 8MB RAM
· Windows 95 or Windows NT 4.0 
· An SVGA 256-color display with 800 by 600 pixel resolution
· Free hard disk space:

      For PC Medic application files: 17MB

      For documentation files: 1MB

 Related Topics 



Installing PC Medic Administrator

1 Start your computer.
2 Do one of the following:

· If installing from a CD-ROM, insert it into the CD-ROM drive.
· If installing from files downloaded from a BBS or the McAfee website, decompress the zipped files into a directory 

on the network or your local drive.
3 Select ”Install PC Medic (Administrator)” from the installation menu.
4 Follow the on-screen instructions.

 Related Topics 



Installing PC Medic Client

Select the type of installation you want to perform: 

Installing from the PC Medic CD-ROM 

Installing from Downloaded Files  

Performing an unattended install 

 Related Topics 



Installing from the PC Medic CD-ROM

1 Start the client computer. 
2 Insert it into the CD-ROM drive.

 Note: If you do not see the PC Medic installation menu appear, run SETUP.EXE.

3 Select “Install PC Medic” from the installation menu. 
4 Follow the on-screen instructions.

 Related Topics 



Installing from Downloaded Files 

If installing from files downloaded from a BBS or the McAfee website, follow these steps:
1 Start the client computer. 
2 Decompress the zipped files into a directory on the network or your local drive. 
3 Run SETUP.EXE.
4 Select “Install PC Medic” from the installation menu. 
5 Follow the on-screen instructions.

 Related Topics 



Performing an unattended install

To perform an unattended installation using software distribution tools, follow these steps:
1 Edit the PCMCRESP.INI response file located in the Client subdirectory on the PC Medic CD-ROM. 

Define the following values: 
· ClientUserName=
· ClientCompanyName=
· FolderName=
· InstallPath=
· Enter the network UNC path that the client will receive policies from. Specify a full UNC path, including the name of

the policy file. The UNC path will look similar to this: \\server\share\path\policy.pcp
· Enter an alternate path to the 2ndOpinion HTML files. You can configure your clients to retrieve the HTML files from

the original PC Medic CD-ROM on a CD-ROM server. The path will look similar to this: HTMLPath=\\server\
share\path

2 Distribute the contents of the Client subdirectory, including the modified response file, to the appropriate workstations 
using your favorite distribution software, such as McAfee’s Zero Administration Client (ZAC).
 Note: Refer to your software distribution documentation for further instructions. 

 Related Topics 



Editing Global Rules

To edit rules for all diagnostic categories, follow these steps:    
1 Open the rule file you want to edit.
2 Select Edit Global Rules from the Rule File menu.
3 Choose User May Diagnose Problems to allow your PC Medic clients to run PC Medic’s Diagnose on their own system.
4 Select the diagnose options you want available to your PC Medic clients. The options include:

· Allow Advanced Mode Diagnostics 
· Allow Silent Mode Diagnostics 
· Allow User to Fix Problems 
· Log Activity     

5 Click the Crash Monitor tab to configure Crash Monitor features and actions.
6 Choose Allow Crash Protection to enable PC Medic’s Crash Monitor services on client systems and specify the actions

that should be taken. Choose from the following actions:
· Log Activity 
· Allow DMI Event Notification 

7 Choose Allow System Monitors to enable PC Medic’s Crash Monitor services on client systems and specify the actions
that should be taken. Choose from the following actions:

· Notify User of Problem 
· Log Activity 

8 Click OK.
9 When you are finished editing the rule file, click Save in the File menu then distribute to the appropriate workstations.
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Editing Rule Files

To edit a specific diagnostic category in a rule file, follow these steps:
1 In the Diagnostic Categories list (Figure 3-1), select the diagnostic category you want to edit. 

The diagnostic categories include:
Applications
Hardware
Hard Drive
Multimedia
Modems/Dial-up Networking
Printing
System Resources
Viruses
Windows

2 Do one of the following:
· Select a diagnostic category then select Edit Rule in the Rule menu
· Double-click the diagnostic category of the rule you want to edit    

3 Choose User May Diagnose Problems to allow PC Medic clients to run PC Medic’s Diagnose service on their own 
systems.

4 Select the diagnose options you want available to your PC Medic clients. The options include:
· Allow Advanced Mode Diagnostics 
· Allow Silent Mode Diagnostics 
· Allow User to Fix Problems 
· Log Activity 

5 Click OK.
6 When you are finished editing the diagnostic category, click Save in the File menu then distribute to the appropriate 

workstations. 

 Related Topics 



Editing a Diagnostic Category

1 Choose User May Diagnose Problems to allow PC Medic clients to run PC Medic’s Diagnose service on their own 
systems.

2 Select the diagnose options you want available to your PC Medic clients. The options include:
Allow Advanced Mode Diagnostics 
Allow Silent Mode Diagnostics 
Allow User to Fix Problems 
Log Activity 

3 Click OK.
4 When you are finished editing the diagnostic category, click Save in the File menu then distribute to the appropriate 

workstations. 



Diagnostic Settings

1 Choose User May Diagnose Problems to allow your PC Medic clients to run PC Medic’s Diagnose on their own system.
2 Select the diagnose options you want available to your PC Medic clients. The options include:

Allow Advanced Mode Diagnostics 
Allow Silent Mode Diagnostics 
Allow User to Fix Problems 
Log Activity 

3 Click OK.

 Related Topics 



Crash Monitor Settings

1 Select the Allow Crash Protection checkbox to enable PC Medic’s Crash Monitor services on client systems and to 
specify what PC Medic should do when a client computer crashes. Choose from the following actions: 
Log Activity 
Allow DMI Event Notification 

2 Choose Allow System Monitors to enable PC Medic’s Crash Monitor services on client systems and specify the actions
that should be taken. Choose from the following actions:
Notify User of Problem 
Log Activity 

3 Save your changes and click OK to close the Global Properties dialog box.
4 When you have finished editing the rule file, choose Save from the File menu. Next, distribute the edited rule file to the 

appropriate workstations



Distribute Rule

To distribute your PC Medic rule files, follow these steps:

 Note: PC Medic Client must be installed and running on all workstations that will receive rule file distributions.

1 Open the PC Medic rule file you want distribute. 
2 Choose Distribute Rules from the Rule menu. Your entire network will appear in the Distribute Rule 

dialog box. 
3 Click + to expand the directory tree for your network, then select the computer that you want to receive the rule file. You 

can also specify the computer’s name with Uniform Naming Convention (UNC) terminology in the computer text box. 

 Note: You must have rights to remotely administer the target computer.

4 Click Properties to view basic information about the remote computer and to verify the location for the rule file. 
5 Click OK to return to the Distribute Rule dialog box.
6 Click Pull to have the remote computer download the rule file from your administrative computer. 
7 Click Send to distribute the rule file to the specified computer.



Remote Computer Properties
Use this page to view basic information about the remote computer and to verify the PC Medic rule file assigned. Select This 
Computer Uses a PC Medic Rule File checkbox to view the PC Medic rule file assigned and it’s location.



Scheduling Actions

1 Enter a description of the action you want to perform in the Description text box.
2 In the Action text box, use the drop-down menu to select one of the following options: 

Diagnose 
Run Application 

3 Enter the program path for the application you want to schedule. You can use the Browse button to locate the application.
4 Enter any additional command-line parameters for the selected application in the Arguments text box. 
5 If you want to specify a program to start the selected application in, enter the program path in the Start In text box. You 

can use the Browse button to locate the program.
6 Use the drop-down menu in the How Often text box to specify the frequency in which the application should run.
7 In the Starting At text box, use the arrow keys to specify the exact time you want the application to run. 

 Note: If you choose Weekly or Monthly, specify the day of the week or the day of the month you want the 
application to run. 

8 In the Options menu, choose from the following options:
Log Activity 
Skip Interval if Missed 



Distributing rule files

To distribute your PC Medic rule files, follow these steps:

 Note: PC Medic Client must be installed and running on all workstations that will receive rule file distributions.

1 Open the PC Medic rule file you want distribute. 
2 Choose Distribute Rules from the Rule menu. Your entire network will appear in the Distribute Rule 

dialog box. 
3 Click + to expand the directory tree for your network, then select the computer that you want to receive the rule file. You 

can also specify the computer’s name with Uniform Naming Convention (UNC) terminology in the computer text box. 

 Note: You must have rights to remotely administer the target computer.

4 Click Properties to view basic information about the remote computer and to verify the location for the rule file. 
5 Click OK to return to the Distribute Rule dialog box.
6 Click Pull to have the remote computer download the rule file from your administrative computer. 
7 Click Send to distribute the rule file to the specified computer.

 Related Topics 



Adding Scheduled Actions

To schedule diagnostic scans or other PC Medic operations to run automatically on your PC Medic client workstations, follow 
these steps: 

1 Do one of the following:
· Select Add Scheduled Action from the Rule menu. 
· Right-click in the Scheduled Actions text box and select Add Action.

2 Enter a description of the action you want to perform in the Description text box.
3 In the Action text box, use the drop-down menu to select one of the following options: 

· Diagnose 
· Run Application 

4 Enter the program path for the application you want to schedule. You can use the Browse button to locate the application.
5 Enter any additional command-line parameters for the selected application in the Arguments text box. 
6 If you want to specify a program to start the selected application in, enter the program path in the Start In text box. You 

can use the Browse button to locate the program.
7 Use the drop-down menu in the How Often text box to specify the frequency in which the application should run.
8 In the Starting At text box, use the arrow keys to specify the exact time you want the application to run. 

 Note: If you choose Weekly or Monthly, specify the day of the week or the day of the month you want the 
application to run. 

9 In the Options menu, choose from the following options:
· Log Activity 
· Skip Interval if Missed 

 Related Topics 



Editing Actions

To edit PC Medic actions described in a rule file, follow these steps:
1 Select the action you want to modify in the Scheduled Actions list.
2 Do one of the following:

· Click Edit Action in the Rules menu
· Right-click the listed action and select Edit Action
· Double-click the selected action

3 Make the necessary edits and click OK.
4 When you are finished editing PC Medic actions, click Save in the File menu then distribute to the appropriate 

workstations. 

 Related Topics 



Configuring Rule Files

PC Medic administration requires rules and schedules that direct each of the client computers on your network to use their local 
copies of PC Medic to perform diagnostic functions and other preventative maintenance. To create or modify these rules, start 
the McAfee Enterprise Client Administration console, then follow these steps:

1 To create a new rule file, choose Save from the File menu then enter a name for the new rule file. The McAfee Enterprise
Client Administrator will save a new rule file with default settings. You can change these rules to suit your needs, then 
save the file again.

To edit an existing rule file, choose Open from the File menu, then select the rule file you want to change. 

 Note: PC Medic administration rule files have a .PCP extension. You’ll find them in the McAfee\PCMedic 
directory. 

2 Choose the type of change you want to make to the file from the Rule menu, see. 

Editing Global Rules 
Editing Rule Files 
Adding Scheduled Actions 
Editing Actions 

3 After you have completed your changes, choose Save from the File menu to save your rule file. Distribute the rule file to 
the appropriate workstations.

 Related Topics 



Allow Advanced Mode Diagnostics
Select this checkbox to allow your PC Medic user’s to run advanced diagnostic scans on their own computers.

 Note: An advanced mode diagnostic scan performs a detailed analysis of your PC. This process may take more time to 
complete than a standard diagnosis. McAfee advises that you use this option if you perform a standard diagnosis, resolve 
the listed problems, and still run into system performance issues.



Allow Silent Mode Diagnostics
Select this checkbox to run diagnostic scans in silent mode. 

 Note: A silent mode diagnostic scan runs the diagnostic process transparently. No status or message prompts will appear as
the program runs.



Log Activity
Select this checkbox to log all PC Medic activity in PCMEDIC.LOG, the PC Medic log file. 



Notify User of Problem
Choose this option if you want the user notified of problems reported by
PC Medic. 



Allow User to Fix Problems
Select this checkbox to allow your PC Medic user’s to resolve problems discovered by PC Medic on their computers.



Diagnose
Choose this option to configure PC Medic's Diagnose application to run at a scheduled time. If you choose this option, continue 
with step 7.



Run Application
Choose this option to configure other applications and utilities to run at a scheduled time. If you choose this option, continue with 
step 4.



Skip Interval if Missed
Choose Skip Interval if Missed to skip the scheduled application if the interval is missed. 

    Note: The scheduled application cannot run if the system is busy or shut down. If this option is not selected and the 
interval is missed, the application will run the next time the system is available.



Allow DMI Event Notification

Select this checkbox to tell PC Medic to send an alert message to a DMI browser when a client’s computer crashes.




